Ezviz h8c 2K+ main stream not working on Hikvision NVR?

LoinKing

Young grasshopper
Joined
Jul 27, 2018
Messages
50
Reaction score
4
Location
Pakistan
I have Ezviz h8c 2K+ camera with latest firmware. Its working perfectly fine on Ezviz Studio/App and shows video in full resolution. I was able to add it easily to Hikvision 7616 nvr and its shows sub-stream on NVR as well. However, when I view camera in full-screen, then it goes blank. I've tried changing frame rate, bitrate etc for main-stream but nothing works.

Anyone know what could be the issue here?
 

alastairstevenson

Staff member
Joined
Oct 28, 2014
Messages
15,944
Reaction score
6,784
Location
Scotland
Anyone know what could be the issue here?
Probably not without a little more basic information about the devices in question.

Hikvision 7616 nvr
What model of NVR and what firmware version?
How are you accessing the NVR - via the VGA/HDMI interface, or the web GUI?

when I view camera in full-screen, then it goes blank.
What codec is the camera set to on sub stream, such as h.264, h.264+, h,265, h.265+
What codec is the camera set to on main stream, such as h.264, h.264+, h,265, h.265+

I'm speculating that it may be an older model NVR that does not support h.265 on the VGA/HDMI interface.
The thumbnail video on a multi-screen usually uses the substream, the full screen usually uses the main stream.
But that's just guesswork at the moment.
 

LoinKing

Young grasshopper
Joined
Jul 27, 2018
Messages
50
Reaction score
4
Location
Pakistan
1. 7616NXI-K2 (latest firmware V4.75.005_230630)
2. NVR supports H.265, other hikvision cameras also running on h.265 and working fine
3. Both main & substream are set to h.265
4. Main stream is failing in live view & playback on HDMI, Web GUI and Hikconnect. Only works if choose substream.
 

alastairstevenson

Staff member
Joined
Oct 28, 2014
Messages
15,944
Reaction score
6,784
Location
Scotland
Ok, that's much clearer.
So - what happens on full-screen if you set h.264 instead of h.265 on main stream for the camera, as a test?
 

LoinKing

Young grasshopper
Joined
Jul 27, 2018
Messages
50
Reaction score
4
Location
Pakistan
FIXED

In Ezviz app. Go to Settings page for the camera. Privacy Settings -> Video Encryption. Disable it. Then reboot camera and NVR.
 
Top