Resource icon

Amcrest Surveillance Pro 2.0 Beta (64-Bit Mac) V2.003.00AC001.0.R.20200321

K.L.

IPCT Vendor
Joined
Feb 18, 2020
Messages
14
Reaction score
17
Location
Houston, TX

CarlosBarletta

IPCT Vendor
Joined
Jan 26, 2021
Messages
17
Reaction score
3
Location
Houston, Texas
Thank you for your feedback. We honestly do value our customer's real world experiences so we can continue to improve on our Technologies. Please feel free to fill out our Support Form by clicking on this link - Amcrest support if you need any assistance down the road. This will be the fastest way to get support from our Support Team.

Thanks again,

Carlos B.
Amcrest Support: Houston, Texas Escalation Team
 

w5yk

n3wb
Joined
Mar 4, 2021
Messages
1
Reaction score
0
Location
La Jolla, California
Wow this is excellent! The new program has a very professional look. I had no trouble getting all my cameras to load. I really like how it is organized into tabs. I was getting a bit frustrated trying to view and manage my cameras on my Mac via the browser interface. I don't think there are any browsers left that show the video feed, and I was thinking I might have to ditch the cameras. This is such a huge upgrade.
 
Last edited:

TheWaterbug

Pulling my weight
Joined
Oct 20, 2017
Messages
146
Reaction score
136
The Amcrest software is functional, but not user friendly:
  1. By default it launches every time with a blank window, and then I need to manually add each "mode" that I want to use, such as Live View, Playback, Devices, and Device Config.
    1. The app should launch in exactly the same state in which I quit the app last time I used it.
    2. There is a preference to reload in the last mode, but that should be the default, not a checkbox buried in the preferences somewhere.
  2. Playback requires tedious, manual entry of the date/time window that I want to Search for events. I must enter both the start time/date and the end time/date
    1. There should be a default setting, such as the previous 24 hours from right now.
  3. Playback timeline shows events only for 1 camera, not for all selected cameras.
    1. In Reolink software, timelines are shown for all selected cameras, so I can see when the action started, e.g. for multiple cameras that cover adjacent areas. This means I can click on whichever event is earlier, and see the whole event:
    2. In Amcrest software I have to go back and forth between the two cameras to see which triggered first, in order to see the whole event, and very often the Sync setting turns off (see below)
  4. Playback does not default to Sync, and the Sync setting gets turned off frequently.
    1. I can't figure out what behaviors cause Sync to turn off, but it happens many, many times while I'm reviewing a day's footage, and it's frustrating.
    2. Sync should be the default, and it should stay selected until manually de-selected
    3. If the user searches for events across multiple cameras, 99.9% of the time they will want to play them back in-sync. By comparison, the Reolink app always plays all selected cameras in sync.
  5. Playback timeline does not "snap" to events. If I see a yellow bar (e.g. an event) in the timeline, I must click exactly on the start of the event, which is difficult when the timeline is zoomed out, in order to view the beginning of the event.
    1. If I click one pixel to the left of the exact start, the app shows nothing.
    2. If I click anywhere inside the timeline, it start playing there, which means I've missed the start of the event, and there is no button for "back to the beginning of the event."
    3. In order to view the very start of an event, I need to zoom all the way in on the timeline, and then mouse very carefully. Then, when I'm done, I need to zoom very far out to find the next event, which makes reviewing the day's footage very tedious.
  6. There also is no button for "skip to next event," so if I know the event I'm watching isn't worth watching through to the end, I need to carefully zoom in and click on exactly the start of the next event.
    1. In Reolink software I just click the "next" button and it takes me to the next event.
  7. High-speed playback is buggy:
    1. When moving the speed slider, the currently-selected speed is not shown until I release the mouse. So selecting 4x may take 2-3 clicks, vs. one click if it showed me when I'm selecting 4x
    2. When Sync is selected, sometimes only one of the videos plays back at 4x, while the other selected camera(s) will sometimes play back at 1x
    3. Sometimes the selected camera will play back at 1x, even if 4x is selected, until the setting is changed to something other than 4x and then back to 4x again.
  8. Exporting clips from the timeline is incredibly unintuitive, and the manual provides no screen shots to help.
    1. When I click the scissors to request a download, the default duration is 1 hour. No one wants an hour of footage by default.
    2. A more useful default would be "this event," since the user will almost always want to download the event that he just viewed.
      1. If an event spans multiple cameras, there should be an option to download footage from all selected cameras, instead of us having to do it individually for each camera
    3. Once I click the scissors again to actually download, I get a warning that, "<camera> is playing back by time. System will need to stop playing back . . . " but playback doesn't actually stop. So either the warning is incorrect, or the software is behaving incorrectly.
    4. The software does not remember my default download preferences, so I have to remember to click MP4 every time I re-launch the software; otherwise I get ASF files. The default download type should be a setting.
  9. The software appears to suspend its connections to the cameras when it's in the background for more than X minutes, which is good, because it minimizes CPU load and network traffic, but when I bring the application to the foreground, the software's behavior is often poor:
    1. Sometimes it takes 5-10 seconds for all the cameras to come back online.
    2. While it's attempting to reconnect to each camera, it often displays the message, "<Camera> Offline!!" and "Failed to open Video!" which is misleading if there's no actual error, and if the camera is just responding slowly. A more useful message would be "Reconnecting to camera. . . " which tells me that I need to wait, instead of telling me there is an error that needs to be fixed.
    3. Perhaps a "keep alive" connection to the cameras could be maintained while the app is in the background, so that reconnection is faster and more reliable when the app is brought to the foreground, but without consuming too much CPU or bandwidth
Anyway, I know this is a lot of feedback, but I use the app every single day to review footage, and I keep running into the same annoyances. I'm hoping for improvement in version 3.0!
 

TheWaterbug

Pulling my weight
Joined
Oct 20, 2017
Messages
146
Reaction score
136
And then these items might be more firmware than software, but I am requesting them anyway!
  1. Settable "pre-trigger" recording interval.
    1. e.g. if set to 5, record 5 seconds of video before the motion trigger event
  2. Post-trigger interval (e.g. the "Delay" setting) of less than 10 seconds
 

Flintstone61

Getting comfortable
Joined
Feb 4, 2020
Messages
733
Reaction score
761
Location
Minnesota USA
Seems comparable in annoyance to my Nightowl HD software used to view the DVR via the PC running blue iris. Esp the part about sync. And timeline playback.
 

JDreaming

Getting the hang of it
Joined
Jul 21, 2020
Messages
10
Reaction score
27
Location
East
Model ADC2W amcrest SmartHome camera can't be viewed on Amcrest-surveillance-pro-2. It will find the camera and shows green light next to it. But you can't do Live View when you click on it.
it will give you a Fail to open Video error. I have 3 Amcrest camera and all works on the older version of Amcrest-surveillance-pro. After upgrade to new version only 2 camera works now. I'm switching
back to the old Amcrest-surveillance-pro.
 
Top