Dahua firmware update works on all but 1 camera - stuck at uploading

AveryFreeman

Young grasshopper
Joined
Jan 24, 2019
Messages
86
Reaction score
20
Location
Near Seattle
Having an issue upgrading my friend's HFW2831T-ZS, he bought 3 from Andy's Amazon store for his restaurant

The reason I started asking about firmware updates is because my friend's HFW2831T-ZS have always acted funny. We have trouble connecting to camera recordings via DMSS app. Related thread: Unhappy with stability of HFW2831T-ZS cameras

Started using Milestone, now camera feed is not stable. Mobile Server in Milestone must be restarted every few hours, otherwise picture says "Connection Lost" (note: Upgrading the firmware has not improved issues with Milestone, perhaps an unrelated issue to not being able to connect to recordings in DMSS until after camera reboot). Milestone Record Server complains of multicast error in logs, so I have turned off Multicast in the cameras to see if that improves stability. I also changed from H265 to H264H hoping that would improve things.

But anyway, re: the firmware - I upgraded 2 camaeras with DH_IPC-HX2(1)XXX-Sag_EngSpnFrn_NP_Market_V2.800.0000000.5.R.200107

The third one is stuck on this:

1609867712653.png

I have tried turning off Windows firewall, adding UPNP mapping, double-checked the network settings (TCP/IP and mapped ports - all default except IP, gateway and DNS)

With configtool get an immediate refusal to connect to that camera:

1609869368824.png
The camera I can't upgrade also happens to be hardest camera to connect to recordings in DMSS - almost never works.

so far I have tried:

Changed IP address
synced PC time
Turned off firewall on PC
Turned off recording in camera
tried Firefox and IE w/ web plugin
Tried Dahua configtool
Enabling UPNP in camera and firewall
Turning off Milestone recording PC firewall

I have not tried TFTP, I could try it, but not sure how to do it via ethernet instead of RS232?

Any help much appreciated, thanks!
 

Attachments

Top